Ardour, Jack, PulseAudio: нет звука

Начало Форум Звук Запись, коммутация, JACK Ardour, Jack, PulseAudio: нет звука

В этой теме 15 ответов, 2 участника, последнее обновление  rusk 6 года/лет, 6 мес. назад.

Просмотр 15 сообщений - с 1 по 15 (из 16 всего)
  • Автор
    Сообщения
  • #1379

    yushi
    Участник

    Здравствуйте.

    Ardour не пишет звук.

    В pavucontrol уровень звука виден, в микшере ничего не заглушено, Audacity через PulseAudio всё нормально пишет. В qjackctl соединяю системные входы со входами дорожки Ardour — успешно соединяется. Микшер Ardour показывает в качестве источника сигнала системные аудиовходы. Но уровень сигнала на нуле, и при нажатии на запись пишется полная тишина.

    Что это может быть?

    #2741

    rusk
    Участник

    в терминале набери alsamixer и посмотри какой источник там выбран (F4 — источники записи, capture). пульс вроде бы сам их переключает (не уверен), но когда включается джек, пульс не работает (должен остаться только один (С) МакЛауд).

    #2753

    yushi
    Участник

    Пишут —
    Card: PulseAudio
    Chip: PulseAudio

    Должно быть что-то другое?

    #2755

    rusk
    Участник

    F6 — выбор звуковой карты. есть ещё варианты кроме пульса?

    когда запущен jack — пульс должен уйти. либо переключиться на pulseaudio-module-jack. А у тебя выходит, что alsa оперирует не железом, а пульсом, что я не понимаю… Я себе пульс удалил совсем.

    #2757

    yushi
    Участник

    Пульса в вариантах вообще нет! Список такой:
    0 SB Live! Value [CT4832]
    1 HDA ATI SB
    2 Microsoftб╝ LifeCam Cinema(TM)

    Без пульса всё ещё хуже, видимо, с ним надо как-то жить. Я тоже его поначалу снёс, но вот как раз разбираясь с Ardour поставил обратно — см. соседний топик.

    #2759

    yushi
    Участник

    Прибил pulseaudio (кстати, на диво малоизвестен нерадикальный — без удаления нафиг — способ это сделать: создать в ~/.pulse/ файл client.conf со строчкой
    [code:14fx6s6q]autospawn = no[/code:14fx6s6q]
    и после этого дать команду pulseaudio -k).

    Запускаю Ardour.

    Картина та же, звука нет. В patchage показывают только три входа от Ardour: control, mcu, sec. В qjackctl входы Audio 1/in 1 и Audio 2/in 2 видны, соединения от системных capture1 и capture2 к ним ведут, но ничего не работает.

    Что самое забавное: при попытке запустить alsamixer получаю:
    ALSA lib pulse.c:229:(pulse_connect) PulseAudio: Unable to connect: Отказ в подключении

    cannot open mixer: В соединении отказано

    Может быть, кто-то поделится конфигами работающей системы, используемой для постоянной и серьёзной работы со звуком? Чтобы я хоть не тратил время на настройку заведомо тупиковых вариантов?

    А то уже много лет пытаюсь получить нормальный набор инструментов для сочинения и записи музыки, а работает всё только с помощью методом тыка нащупанных костылей, обыкновенно слетающих при следующем dist-upgrade.

    P.S. Ещё один эффект появился: Ardour отказывается открывать собственные проекты, созданные после апгрейда. Ранее созданные проекты открываются нормально, послушать записанное я могу.

    #2760

    rusk
    Участник

    посмотри что написано в файле .asoundrc в домашнем каталоге.

    попробуй установить cadence из репозитория kxstudio. Вроде бы там всё организовано так, чтобы пульс с джеком работали вместе.

    #2761

    yushi
    Участник

    [quote:2f64uvt8][b:2f64uvt8]rusk написал:[/b:2f64uvt8]
    посмотри что написано в файле .asoundrc в домашнем каталоге.[/quote:2f64uvt8]

    [code:2f64uvt8]uri@serpent ~ $ cat ~/.asoundrc
    # ALSA library configuration file

    # Include settings that are under the control of asoundconf(1).
    # (To disable these settings, comment out this line.)
    </home/uri/.asoundrc.asoundconf>

    uri@serpent ~ $ cat ~/.asoundrc.asoundconf
    # ALSA library configuration file managed by asoundconf(1).
    #
    # MANUAL CHANGES TO THIS FILE WILL BE OVERWRITTEN!
    #
    # Manual changes to the ALSA library configuration should be implemented
    # by editing the ~/.asoundrc file, not by editing this file.
    pcm.!default { type pulse }
    ctl.!default { type pulse }[/code:2f64uvt8]

    В общем, через пульс ему прописано работать. Это надо как-то поменять?

    [quote:2f64uvt8][b:2f64uvt8]rusk написал:[/b:2f64uvt8]
    попробуй установить cadence из репозитория kxstudio. Вроде бы там всё организовано так, чтобы пульс с джеком работали вместе.[/quote:2f64uvt8]

    Не всё, что Linux — Ubuntu. =) У меня, в частности, не Ubuntu, поэтому репозиторий kxstudio мне не подойдёт. Но на cadence посмотрю, спасибо.

    #2762

    rusk
    Участник

    [quote:2xwmsc7b]Это надо как-то поменять?[/quote:2xwmsc7b]

    http://alsa.opensrc.org/.asoundrc

    надо чтобы так: железо -> alsa -> jack

    #2765

    rusk
    Участник

    http://planetsecurity.org.ua/linux/linu … audio.html

    вот тут примерно описан источник проблемы

    [quote:3qzwfllq]но по сути перед вами виртуальное устройство — вывод ALSA передается на PulseAudio и обратно на ALSA[/quote:3qzwfllq]

    Поэтому я предпочёл удалить пульс совсем. И пока не испытываю никаких неудобств.

    #2766

    rusk
    Участник

    а kxstudio вроде и на другие дистрибутивы есть. Я видел там Arch и Debian точно.

    #2767

    rusk
    Участник

    [quote:28jjmhcl]Поэтому я предпочёл удалить пульс совсем.[/quote:28jjmhcl]

    Плюсы:
    — при использовании alsa-jack в jack каждый клиент появляется отдельно а не один на весь пульс как раньше.
    — исчез сильножручий процесс пульса.
    — Стал нормально работать скайп.
    — пявилась возможность писать разговор скайпа (И любого источника, даже flash плэйера из браузера) без проникновения остальных системных звуков.
    — Апплет громкости теперь аппаратными кнопками регулирует общий выход ALSA а не пульса.

    Минусы:
    — периодически jack падает от простого aplay.

    #2768

    yushi
    Участник

    Вернул на место обнаруженный в бэкапах старый ~/.asoundrc:
    [code:2kud0ypf]pcm.!default {
    type hw
    card 0
    device 0
    }[/code:2kud0ypf]

    PulseAudio прибил. Но alsamixer всё равно отказывается запускаться, сообщая, что не может соединиться с PulseAudio. В чём может быть дело?

    Входных портов Ardour в patchage по-прежнему не видно, звук на вход не пошёл.

    #2769

    yushi
    Участник

    Да, а где можно найти исходники Cadence или хотя бы сервер какой-нибудь системы версий, где они лежат? На http://sourceforge.net/projects/kxstudi … /Releases/ их почему-то нет…

    #2770

    rusk
    Участник

    <img src=» title=»Wink» />

    в гугле как всегда.

    http://repo.or.cz/w/cadence.git

    А ещё, если дист не убунту, то в том же гугле «<имя дистрибутива> remove pulseaudio». Про убунту в гугле везде написано по русски как это грамотно сделать а также как вернуть на место если вдруг непонравится.

    [url:yp4qev0y]http://help.ubuntu.ru/wiki/%D1%83%D0%B4%D0%B0%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5_pulseaudio[/url:yp4qev0y]

Просмотр 15 сообщений - с 1 по 15 (из 16 всего)

Для ответа в этой теме необходимо авторизоваться.