[Решено][Ubuntu][ALSA] E-mu 1616m pci-e

Начало Форум Звук Аппаратное обеспечение [Решено][Ubuntu][ALSA] E-mu 1616m pci-e

В этой теме 21 ответ, 2 участника, последнее обновление  mcdebugger 5 года/лет, 8 мес. назад.

Просмотр 7 сообщений - с 16 по 22 (из 22 всего)
  • Автор
    Сообщения
  • #2578

    lembergus
    Участник

    Правда внешний модуль почему-то греется жутко.

    #2579

    lembergus
    Участник

    И всё-таки поменял clock rate на 44100, потому что ни banshee, ни флешплеер 48000 не понимают и воспроизводили мне всё слегка ускоренно)

    #2580

    mcdebugger
    Участник

    [quote:2fa3q2fx][b:2fa3q2fx]slipped_on_blade написал:[/b:2fa3q2fx]
    И всё-таки поменял clock rate на 44100, потому что ни banshee, ни флешплеер 48000 не понимают и воспроизводили мне всё слегка ускоренно)[/quote:2fa3q2fx]

    ога, я писал про эту штуку тоже <img src=» title=»Smile» />
    P.S. док и должен греться, это, увы, фишка этих карт.
    P.P.S. а ещё говорят, что gentoo недружелюбна к пользователю ))
    мне было достаточно
    emerge alsa-firmware
    cd /usr/src/linux && <apply patch> && make nconfig
    make -j12
    make install && make modules_install
    boot-update [опционально]
    reboot

    <img src=» title=»Smile» />

    P.S. карту использую только совместно с JACK, музыку слушаю либо через встроенную Штеуд HD, либо изредка через pulse-jack

    Поздравляю с побьедой! Хорошей музыки, творческих успехов и прекрасного качества звучания. Да, слушал Ваши треки из соседнего раздела, интерес-сненько)

    #2581

    lembergus
    Участник

    Спасибо. Правда с jack небольшая проблема — примерно раз в минуту раздаётся неприятный громкий треск. Как я понял, проблема решается увеличением значения Frames/Period, но вместе с ним увеличивается и задержка, которая становится заметна при значениях больше 10 мс. Не подскажете, как с этим можно бороться?

    P.S. На самом деле убунта дружелюбна только когда всё железо обычное и весь софт из репозиториев. А так — шаг влево = смерть.

    #2582

    mcdebugger
    Участник

    [quote:1n8sb6zv][b:1n8sb6zv]slipped_on_blade написал:[/b:1n8sb6zv]
    Спасибо. Правда с jack небольшая проблема — примерно раз в минуту раздаётся неприятный громкий треск. Как я понял, проблема решается увеличением значения Frames/Period, но вместе с ним увеличивается и задержка, которая становится заметна при значениях больше 10 мс. Не подскажете, как с этим можно бороться?

    P.S. На самом деле убунта дружелюбна только когда всё железо обычное и весь софт из репозиториев. А так — шаг влево = смерть.[/quote:1n8sb6zv]
    Ну или как вариант сменой железа <img src=» title=»Smile» />
    P.S. у меня стоят следующие значения:
    period: 128
    nperiods: 2
    (JACK2)
    изредка когда запускаю винду под виртуалкой и связываю её через netjack, ставлю period: 256, т.к. иногда возникают дропы в серьёзных треках.
    но и железо специально для этих нужд пришлось обновлять. CPU: AMD Phenom(tm) II X6 1075T Processor, 8 GB DDR3. но на старом железе (Pentium 4 Prescott 3.0 Ghz), в общем-то, тоже на малых period работало в не очень тяжёлых проектах.

    [b:1n8sb6zv]Вы ещё проверьте, не суёт ли свой нос PulseAudio куда не нужно. Особо сильных щелчков быть не должно, лишь некоторый glitch звука.[/b:1n8sb6zv]

    #2583

    lembergus
    Участник

    Пульсы у меня нет, я её снёс и работаю напрямую с альсой — так удобнее. Железо у меня нормальное, недавно систему обновлял, но эти щелчки и потрескивания напрягают. Придётся поковыряться и найти оптимальные настройки.

    #2934

    mcdebugger
    Участник

    Наконец-то нашёл время нарисовать гит-патч по этой наболевшей теме. Патч применён в sound.git на git.kernel.org, будем надеяться, с ближайшими выпусками ядра головной боли у многих поубавится и будет достаточно только указать нужные опции в конфиге ведра (если самосборное) и подсунуть alsa-firmware.

Просмотр 7 сообщений - с 16 по 22 (из 22 всего)

Для ответа в этой теме необходимо авторизоваться.