Рассинхронизация видео и аудио.

Начало Форум Видео Монтаж Рассинхронизация видео и аудио.

В этой теме 15 ответов, 6 участников, последнее обновление  Sniff 5 года/лет, 11 мес. назад.

Просмотр 15 сообщений - с 1 по 15 (из 16 всего)
  • Автор
    Сообщения
  • #763

    snakeRU54
    Участник

    Здравствуйте.
    При создании проекта видеоролики подгружаются нормально. Наблюдается небольшая задержка между нажатием «Play» и началом воспроизведения видео, примерно полсекунды. Я думаю, что это из-за недостаточной мощности компьютера.
    Но стоит только переместить видеоролик по временной шкале — происходит рассинхронизация аудио и видео в этом ролике. Аудиотрек как будто остаётся на том месте, где был соответствующий видеотрек. Затем аудио пытается «догнать», вырезая упущенный участок. Но полной синхронизации аудио и видео не присходит. Отмена перемещения видеоролика по временной шкале не помогает — «косяк» сохраняется.
    Сам файл при этом не бьётся. Если закрыть программу и открыть снова — никаких рассинхронизаций не будет, до момента перемещения.
    Помогите.

    UBUNTU 11.10
    Intel i5
    4 GB оперативной памяти

    #1069

    Всё замечательно в описании, только программа-то какая? :)

    #1071

    snakeRU54
    Участник

    Хм, вот ведь я балбес))) Никогда не пишите с работы про дела домашние.
    Программа kdenlive 0.8
    Сейчас запустил тот же проект, видеоклип уже «передвинутый», с косяком. Так вот теперь косяков нет.
    Клип я попередвигал, но видео и аудио не рассинхронизировались. Пока что.
    Подвигаем, понаблюдаем.

    #1073

    snakeRU54
    Участник

    Возвращаемся к нашим баранам.
    Сейчас загрузил в проект двухминутный клип в формате AVI.
    Проверил воспроизведение внутри проекта — никаких ошибок.
    Вырезал из клипа участок в пять секунд, сдвинул части ролика.
    Опять появились торможения звука, заикания и отставание.
    Что делать, куда копать?

    #1076

    snakeRU54
    Участник

    Люююююди! Отзовитесь!
    Что, никаких идей нету?

    #1077

    А что за контейнер/кодек у вставляемых в проект данных?

    #1078

    snakeRU54
    Участник

    Информация, полученная из свойств видео-файла (не знаю, насколько она исчерпывающа)

    ВИДЕО
    размер 640 х 480
    кодек Motion JPEG
    частота кадров 30
    скорость потока неизвестна

    АУДИО
    кодек uncompressed 8-bit PCM
    каналы МОНО
    частота дискретизации 11024
    скорость потока неизвестна.

    Все ролики записаны фотоаппаратом

    #1079

    Rodegast
    Участник

    У тебя исходник в NTSC, а проект скорее всего в PAL. Это может дать рассинхрон.

    #1080

    snakeRU54
    Участник

    Rodegast написал:
    У тебя исходник в NTSC, а проект скорее всего в PAL. Это может дать рассинхрон.

    спасибо за наводку.
    Верно, был PAL.
    Но.
    Я попробовал изменять настройки проекта — перебрал несколько режимов NTSC.
    Косяк остался на месте.

    Может, именно со звуком какие-то проблемы? Как узнать?

    #1081

    snakeRU54 написал:
    Может, именно со звуком какие-то проблемы? Как узнать?

    Залил жалобу в трекер

    Пусть помучаются :)

    #1082

    snakeRU54
    Участник

    И, кстати, вот ещё соображение.
    Ролики, которые я пытался обрабатывать (записанные фотоаппаратом) — скорее всего, никак не компрессованы.Может, ещё и в этом дело.
    Неделю отсутствовал — ничего нового скащать не могу.
    Сегодня-завтра попробую редактировать видео из различных источников.
    О результатах отпишусь.

    #1084

    alphaed
    Участник

    Такая же беда.

    монтирую из клипов
    ВИДЕО
    размер 640 х 480
    кодек Motion JPEG
    частота кадров 30
    скорость потока неизвестна

    АУДИО
    кодек uncompressed 8-bit PCM
    каналы МОНО
    частота дискретизации 11024

    в разных местах звук подтормаживает 1-2 раза за клип.
    Что на предпросмотре, что в собранном ролике.
    Исходные клипы в плеерах смотрятся и слушаются нормально.
    Исходники тоже были сделаны фотиком, в avi.

    Обновил из ppa разрабов kdenlive, не помогло (

    тоже ubuntu 11.10.

    Интересно, ТС как-то решил проблему?

    #1085

    alphaed
    Участник

    Решил проблему полным разделением исходных клипов (звука и видео) — выделение звука в отдельный wav файл.
    Не особо удобно, но другого варианта не нашел.

    #1086

    mcdebugger
    Участник

    Частичный оффтоп, но поспешу сообщить, что совсем недавно (пару-тройку дней назад) решил аналогичную же проблему аналогичным же способом… только в blender VSE. Прям кросс-софтверная зараза какая-то :)

    #1087

    А может быть всё дело в FFmpeg? :)

Просмотр 15 сообщений - с 1 по 15 (из 16 всего)

Для ответа в этой теме необходимо авторизоваться.