jackd -T не завершается

Начало Форум Звук Запись, коммутация, JACK jackd -T не завершается

В этой теме 7 ответов, 4 участника, последнее обновление  kostolen 4 года/лет, 4 мес. назад.

Просмотр 8 сообщений - с 1 по 8 (из 8 всего)
  • Автор
    Сообщения
  • #1419

    Suner
    Участник

    Установил новую убунту 12.10 (до этого использовал xubuntu 11.04), а тут jackd не завершает свою работу при отключении клиентов, хотя ключ -T указан! Почему? Не могу понять… patchage никаких других клиентов не показывает… Закрываю все клиенты и patchage тоже, и всё равно jackd работает.
    Jackd запускаю через /etc/jackdrc как
    [code:2q2g5iy9]/usr/bin/pasuspender — /usr/bin/jackd -T -dalsa -d hw:1[/code:2q2g5iy9]

    #2963

    kostolen
    Участник

    Этому багу с джеком несколько лет. по какой-то бородатой причине jackdbus не может корректно завершиться. Он вроде как завершается и снова стартует. Чтобы это сделать ему надо послать сигнал через команду [code:6tttoef2]killall -s KILL jackdbus[/code:6tttoef2] в qjackctl делается просто, а как это приделать к вашим скриптам, там уж сами.
    P.S.Вот бы Линус Турвальдс бросился их (разработчиков) ругать за подобные гадости, столько лет не осилят такую простую проблему… С Пульсом в последнее время меньше проблем чем с джеком вам не кажется?

    #2970

    Suner
    Участник

    Спасибо за ответ!

    [quote:3n97u50o][b:3n97u50o]kostolen написал:[/b:3n97u50o]
    Пульсом в последнее время меньше проблем чем с джеком вам не кажется?[/quote:3n97u50o]
    А у меня никогда и не было никаких проблем с пульсом, а вот с джеком были…

    #2981

    lazyklimm
    Участник

    [quote:lu5armqn][b:lu5armqn]kostolen написал:[/b:lu5armqn]
    Этому багу с джеком несколько лет. по какой-то бородатой причине jackdbus не может корректно завершиться. Он вроде как завершается и снова стартует. Чтобы это сделать ему надо послать сигнал через команду [code:lu5armqn]killall -s KILL jackdbus[/code:lu5armqn] в qjackctl делается просто, а как это приделать к вашим скриптам, там уж сами.
    P.S.Вот бы Линус Турвальдс бросился их (разработчиков) ругать за подобные гадости, столько лет не осилят такую простую проблему… С Пульсом в последнее время меньше проблем чем с джеком вам не кажется?[/quote:lu5armqn]

    не кажется, я эту ересь не использовал никогда за ненадобностью :)

    А jack уже больше 5 лет — никаких проблем

    #2982

    pavluxa
    Участник

    приветствую, если есть кто живой.
    смотрел, куда написать — решил сюда(самый свежий пост).

    у мну, как у всякого начинающего линуксоида — проблемы <img src=» title=»Smile» />
    (а александр что-то со статьей для новичков затягивает).
    итак, что имеем — дистр дебиана(с рутрекера от алекса_usb ).
    jack и сопутствующие ему поставил.
    поставил qtractor и qsynth(в плане послушать мидишки через эту связку
    — чевой-то не слухаются).
    ладно, запускаю джек, qsynth. в кач-ве миди-клавы — xstation,
    звуковуха м-аудио фаст трек (а, забыл — ядро воткнул с репы avlinux
    3.6.6-rt-avl) — пытаюсь поиграть — фигушки. звука нэттт!
    с виртуальной клавы есть(в джеке во вкладке миди она появляется,
    а х-стэйшен — нет. только в альсе).
    вот скрин [img]ac83abd7e58ce7b4a81a2864d6769b84.jpeg[/url:ec4wiebl]

    подскажите, куда рыть, пж-та.

    #2983

    kostolen
    Участник

    Не лучше ли было бы создать новую тему?
    И не совсем понял этой фразы [quote:b4qp6fo9]с виртуальной клавы есть(в джеке во вкладке миди она появляется, а х-стэйшен — нет. только в альсе).[/quote:b4qp6fo9] У Вас Qsynth появляется во вкладке MIDI а х-стэйшен в ALSA? Надо настроить в Qsynth — чтобы использовал аудио драйвер jack а миди драйвер alsa — тогда всё появится…. я так думаю <img src=» title=»Smile» />

    #2984

    pavluxa
    Участник

    прошу прощения за тормоза в ответе.
    итак — простая задача:
    запустил джек;
    воткнул ку-синт;
    вирт. миди-клава — жму — звук идет из встроеной карты(ноут + м-аудио)
    в параметрах звука по умолчанию — м-аудио
    во вкладке «звук» джека ку-синт соединен с систем
    «миди» — вирт-клава с ку-синтом
    «альса» — нет ничего, кроме миди-сквозняка

    в параметрах джека префикс «как обычно», др-р звука — альса, драйвер миди — нет.
    что нужно «крутить»? <img src=» title=»Smile» />
    извините за тупость — что-то я совсем растерялся: ставил танго-студию на стационар, подключал м-аудио, пробовал связку ку-трактор+ку-синт — мидишки слушал. потом, как обычно — у тебя ноут есть — с ним и ковыряйся <img src=» title=»Smile» />
    а на ноуте — дебиан…

    пысы:сейчас в джеке выбрал миди-драйвер raw, в ку-синте: звук — альса.
    пошло через м-аудио!
    но, что ж получается — ку-синт из вкл»звук» джека исчез..?

    пысы2: раз звук пошел — втыкаю х-стэйшен.
    в джеке на вкл»миди» кроме вирт.клавы появляется «систем» —
    считаем, что это х-ст-н и соединяем с ку-синт. звук есть.

    пысы3:пробую ку-трактор подключить в этом конфиге — тишина…

    #2985

    kostolen
    Участник

    моя рюськи плоко панимаит
    [quote:15d6jl78]запустил джек;
    воткнул ку-синт;
    вирт. миди-клава — жму — звук идет из встроеной карты(ноут + м-аудио)[/quote:15d6jl78]
    Что жму? где жму?

    В джеке используются две системы передачи MIDI и соединений, один через alsa другой через jack(который на вашем скриншоте — вкладка MIDI) Qsynth у Вас, очевидно, настроен на работу с MIDI через jack, поэтому он появляется во вкладке MIDI. Почему так происходит — вопрос не ко мне, НО! Я написал что надо настроить в Qsynth. Вы это делали или просто «палочкой тыкаете»?

Просмотр 8 сообщений - с 1 по 8 (из 8 всего)

Для ответа в этой теме необходимо авторизоваться.